Disclaimer: The objective of the tutorial is not to create an expert in VISSIM modeling but to get a new user sufficiently (and quickly) up to speed so they can use the manual and other resources when they have questions on model development. That is, helping a new user past the frustrating “which button do I press” part of the learning curve. These tutorials should not be considered as official methods or guidance in any way. It is certainly possible other modeling experts may disagree with portions of the tutorial or there is an outright error in the tutorial. However, it is hoped, the tutorials provide a good start on the process of model development. If you find any errors or issues please feel free to let us know at michael.hunter@ce.gatech.edu so we can update the material.

VISSIM (V5.10) Tutorial Overview

This tutorial will guide you through the creation of a network which consists of 3 intersections and 8 legs. The network is regulated by fixed time signal controllers.

There are four main components for the network creation:

1. Links and connectors – the actual “roads and intersections” of the network.
2. Traffic controllers – the signals controlling traffic movement.
3. Traffic volumes and routing decision – settings that control the traffic volume and permitted movements.

First start VISSIM: start → all programs/programs → PTV_Vision → VISSIM 5.10

Navigating the View Screen

VISSIM has two display settings: Normal Display (default) or Centerline Display. Normal shows each link (roadway segment) as a full-width roadway. This tutorial is shown in centerline display, which shows each link as just the centerline.

There are three ways to change the view. 1) Go to View → Options. The Display Options box will open. Under the tab titled Network, select Center Line. 2) View → Options → Centerline, or 3) you can toggle between the two views by pressing Ctrl-A.

To zoom in and out on the view screen use the Zoom button: in the left toolbar. Left Click to draw a box around the area you want to zoom in on. Right Click to go back to the last view. You can also use the scroll wheel on your mouse to zoom, but this only zooms on the center of the screen. Press and hold the control drag your view around the screen

NOTE: As you are working on creating a network, save the file as you work. You don’t have to create the entire network at once. You can save it and come back to it. VISSIM does NOT save automatically.

Changing to Customary Units

Since VISSIM was developed in Karlsruhe, Germany the default units are metric.

- Select View → Options from the menu bar
- In the Language & Units tab change all the drop down boxes to customary units
Part 1: Links and Connectors

Intro: the basic element of a VISSIM network is called a “link.” A link represents a single or multiple-lane roadway segment that has one specified direction of flow. Therefore, a two-way roadway is constructed of two links with opposite directions of flow.

A network can be built by connecting these links with connectors. Only connected links allow for continuing traffic. Links that simply overlap or cross one another (without connectors) have no interaction with each other.

1.1 Creating Links
- Click the link icon: in the left toolbar.
- With the right mouse button click at the desired start position of the link, drag the mouse in the direction of flow to the destination position and release the button
- While dragging the mouse, the length of the link is visualized in the status bar at the bottom (Fig. 1). Create an east-west link (north is towards the top of the screen) of length 2800 (± 20) ft.
- Once you reach the end of the link and release the button, a window will pop-up containing the link data (Fig. 2):
  - Set the number of lanes equal to 2
  - Check the box next to Generate Opposite Direction option to create a parallel link in the opposite direction (insert the same Number of Lanes).
  - Keep all the other default values and click ‘OK’

- Repeat this procedure to create north-south links at about 700 ft, 1400 ft and 2100 ft along the east-west roadway
  - Make all north-south links 1500 (± 20) ft
  - Set the number of lanes to 1 for all north-south links
- Create turning pockets in the middle intersection by drawing two short links (approximately 150 ft). Remember to draw them in the direction of flow.
- NOTE 1: Make room for the turning pockets by moving the horizontal links apart. The distance between the center lines should be approximately 50 ft (Fig. 3).
  - To move a created link, select the link and while holding down the SHIFT key, left click on the link and drag it to the desired position.
- NOTE 2: Make sure you leave enough room for the connectors, that is: do not drag the links all the way to the middle of the intersections. The intersection “box” should have dimensions approximately 80x80 ft (Fig. 3).
- You now have completed the network “backbone” (Fig. 4)

1.2 Creating Connectors
- With the right mouse button click at the desired start position inside a link, drag the mouse in the direction of flow to the position inside the destination link, and release the mouse button. Here you are creating the left and right turning movements.
- Upon releasing the button the connector edit window will pop-up
  - Change the From Link and To Link boxes in case of mismatch between lanes:
    - Example: for the west to north (or the connectors to the turning pockets) highlight Lane 2 in the left window and Lane 1 in the right one (Fig. 5).
    - Lane 1 is always the closest to the edge of the road.
  - Change the Spline’s # Points (Fig. 6) in a range between 2 to 4 for straight connector, and 2 to 15 for turning connectors.
  - The higher the spline # Points, the rounder the turn – try 5 points for right turns and 10 for left turns. You can change this attribute later if you are not satisfied with the roundness of the turn.
  - Keep all the other default settings and click ‘OK’
- Repeat the procedure for EVERY movement of EACH intersection (turning pockets included). **Fig. 7** shows the final connected network.
- Each intersection should have 8 connectors. The middle intersection should have two additional links to the turn pockets
- Sometimes you will be unable to click on the desired link/connector endpoint because multiple links/connectors come together and overlap one another at the endpoints. To toggle from one link/connector endpoint to another, click the desired location and then click the **icon (or the TAB key)** to toggle through the overlapping items.

**Figure 5.** From west to north connector

**Figure 6.** Connector data

**Figure 7.** Complete network’s links and connectors
Part 2: Traffic Controllers

Adding traffic control devices is a two step process. First, signal controllers must be created and specific timing for the signal group phases entered. Second, signal heads are placed at the intersections and the applicable SC number and signal group phase is assigned to that specific head.

A time diagram is shown below in **Fig. 8**. The top diagram displays the signal timing for the two side intersections while the bottom diagram shows the signal timing for the middle intersection.

**Figure 8.** Time diagram for signal controllers. (G = green time, Y = amber time, AR = all red time)
- Top diagram has permitted left turns in both directions
- Bottom diagram has protected left for E-W, and permitted left turns N-S.

The signal controller that will be used is called a Ring Barrier Controller (RBC) which uses the Dual Ring logic. For this purpose, you need to define the signal groups for each turning movement. Typically 2 and 6 are the mainlines so for this example, we will use the following phase numbers:
2.1 Coding Signal Data
- On the top, from the menu bar select *Signal Control → Edit Controllers*.
- The *Signal Control* window will pop up. Now you need to create two different controllers, one for the middle intersection and one for the side streets.
  - In the left-hand part of the window, Right-click and select “New”
  - A new controller will be added in this window. This effectively represents one signal control cabinet that one would find at an intersection in the field. All phases will be defined for this controller in the following step.
  - Assign a number (No. 111), a descriptive name (e.g. Side Cross Road).
    - *Side Note:* We will only create one controller titled “Side Cross Road.” This is because we can apply this controller to both intersections as both intersections are effectively the same.
  - Change the controller Type to “Ring Barrier Controller” (you may need to scroll up to find it).
  - Now click on the “*Edit Signal Groups*” box and a new window will pop up.

(The tree on the left contains all the settings, more advanced options, and patterns used for more complex controllers. Clicking on the + or – expands or collapses options, and checking and un-checking the boxes will show or hide the settings).

- The first step is to define the Signal Groups. When you’re placing signal heads you will be able to reference the SG Numbers you create.
  - Under *Base Timing* → *Timing by SG* → *Basic*, enter 2, 4, 6, 8 for SG Numbers
  - Now insert the following signal timing data: *(Also see Fig. 10)*.

<table>
<thead>
<tr>
<th>SG Number</th>
<th>2</th>
<th>4</th>
<th>6</th>
<th>8</th>
</tr>
</thead>
<tbody>
<tr>
<td>Min Green</td>
<td>30</td>
<td>20</td>
<td>30</td>
<td>20</td>
</tr>
<tr>
<td>Max 1</td>
<td>30</td>
<td>20</td>
<td>30</td>
<td>20</td>
</tr>
<tr>
<td>Yellow</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td>3</td>
</tr>
<tr>
<td>Red Clear</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>Max Recall</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>

You must check Max Recall so that the other phases will be called.

- Under *Base Timing* → *Sequence*, you need to arrange the signal group numbers into separate rings and form barriers to model the dual ring logic. For the first intersection enter the numbers 2 and 4 in Ring 1, and 6 and 8 in Ring 2. To set up the barrier, move the mouse to the area between 2 and 4 and directly above it. Your cursor will turn into “+/−”. Double clicking will add/remove the barrier *(Fig. 9)*.
  - Placing barriers will tell the controller which signal groups must begin or end at the same time.
The RBC dialogue for the Side Cross Road is shown in Fig. 10 below:

When you click OK, it will prompt you to save the RBC file. Save it in the same folder you’ve been working in as “RBC111” and click OK.
- Repeat the same procedures for the middle intersection.
  - Right click on the left side and select “New”.
  - Give this intersection a number (No. 222) and name (Mid Cross Rd).
  - Select “Ring Barrier Controller” as the Type.
  - Enter the information as shown in Fig. 11. This controller will include additional phases 1 and 5 for the protected left turns.

The RBC dialogue for the middle intersection is shown in Fig. 11:

(**Note the different Sequence for the second controller).
Placing Signal Heads

- After defining the signal controller characteristics we can now place the signal heads at the intersections.
- Click the signal heads icon :  
- Left click a link to select it.
- Place the signal head on the through link by right clicking inside the link. The signal head should be placed inside the link, not across from it as it would in a real-world intersection.
- The traffic head data window will pop-up (Fig. 13)
  - Assign a number and a descriptive name to the signal head – these are specific to each signal head in each lane.
  - Assign to the Lane field the lane # that the signal head is controlling
  - Select the SC (Signal Controller) and Signal Group created previously according to the intersection and turning movement. Then click ‘OK’.
  - Repeat the procedure for every signalized lane. There should be a total of 20 signal heads. Signal heads in adjacent lanes within one link should be approximately aligned. (See Fig. 15 for signal head placement locations)
  - For right turn connectors, put the traffic head on the link, overlapping the connector (Fig. 14). This is necessary to allow right turn on red.

![Figure 13. Signal Head edit window](image)

![Figure 14. Placing the signal heads to implement right turn on red.](image)

![Figure 12. Side Streets (SC No. 111)](image)

![Middle Intersection (SC No. 222)](image)
2.3 Right Turn on Red

Concept: The cars that will be turning right on red are not affected by the signal head placed in the previous section because it was placed passed the right turn connector. We will place a stop sign on the right turn connector that will control any car turning right.

Note: For any right turn on red movement, you do not need a signal head controlling it (ex: right turn dedicated lane does not require a signal head if it does not receive a dedicated right turn, you will only need to place the stop sign. This is not shown in this tutorial.)

- Click the Stop Sign icon
- Left click on the right turn connector
- Right click at the location where the cars will stop to make the right turn on red movement and the Create Stop Sign Window will appear

- Click on the RTOR tab and check the Only on Red box
- Select the SC: Signal Control number which is controlling the intersection where you are placing the stop sign
- Select the SG: Signal Group which controls the movement where the car is attempting to make a right turn
- EX: For a car driving northbound at the third intersection choose the SC: 222 and the SG: 4 to allow the RTOR
- Repeat process for any allowed right turn on red movement
Part 3: Traffic Volume & Routing Decision

3.1 Traffic Volume

- Click the Vehicle Inputs icon:
- Double left click an entering link (one of the links entering the network) and the Vehicle Inputs window will pop up
- Click ‘New…’, the Create vehicle input will pop up (Fig. 16):
  - Assign a number and a descriptive name
  - Fill up the Volume field: 300 for north/south links, 600 for east/west links
  - You will have to click on the box below the input and select 1: Default
  - Keep all the other default settings
- Repeat the procedure for all the links entering the network. In the end, right click a point outside the network to check you have 8 traffic volumes defined (Fig. 17).

3.2 Routing Decisions

The procedure to create routing decisions is similar to that for creating connectors. For each link entering an intersection you will have to define the permitted movements at that intersection for approaching vehicles. In the case of our simple “side intersections,” this consists of a right-turn, left-turn, and through movement.

- Click the Routes icon:
- Left click a link that enters an intersection
  - Right click a point inside the link approximately 150 ft from the intersection (Fig 18). A red bar will appear at that location on the link - this is your routing decision starting point

Figure 16. Vehicle Input window

Figure 17. Traffic Volumes defined

Figure 18. Routing decision’s starting point (at least 150 ft from intersection).
- Upon releasing the button the *Creating routing decision* window will pop up.
- Within the *Create Routing Decision* window, leave all the default values and click ‘OK’ to close the window.

- Now you have to define the 3 possible routing destination (left, right, straight):
  - Left click to select the destination link
  - Right click a point past the intersection. A green bar will appear at that location - this is your destination point.
  - Repeat the procedure for the other destination.

- Once you have defined the 3 routing destinations for one link, restart the procedure for the others by clicking the routing decision icon. **Fig. 19** shows a fully routed intersection (notice: 1 red bar for entering links, 3 green bars for exit links)

- Where there is only one possible turning movement (such as when exiting the left turn pockets), no routing decision is necessary. Routing decisions are only required where there are multiple connectors leading away from a link.

- The routing decision points for the middle intersection have to be placed before the links of the pocket connectors (**Fig. 20**). The routing decision can be only to the turn pocket or it can go all the way through the intersection, both will work. It is only necessary to send it to the turning pocket because there is only one path for vehicles to travel on.

### 3.3 Relative Flow

Within each of the routing decisions we’ve constructed, there are three routes associated with each decision (at a decision point a driver can either continue straight, turn right or turn left), except along the arterial at the center intersection, where there are only two (continue straight or turn right) because of the left turn bay. The default of VISSIM is to have an equal percentages of vehicles continue straight, turn right or turn left. However, in some cases (such as an arterial) you can assign relative flow percentages to each route within one decision.

- Left click a point outside the network to open the *Routes* window with a list of routing decisions and scroll through each of them (**Fig. 21**)

- Within this *Routes* window, note that each *Route #* for a given *Decision #* is listed in the central part of the window. The fifth column (with heading “0-99999”, denoting that this is valid from time 0 to time 99999)
Within this column, you can assign relative flow to each route number of each decision (% of vehicles that go left, right, or straight). These are relative percentages and do not have to sum to 100% - VISSIM will recalculate percentages relative to the values you enter. For example, you could enter 4, 4, & 8 to represent 25%, 25% and 50%, or 4, 4, & 4 to represent 33.3%, 33.3% and 33.3%.

Go ahead and enter 20 for each turning movement (including 20 for the decision to enter the left turn bay) and 50 for each through movement.

Note that at times while working on routing decisions, the visual display will appear as part of the network has been deleted (Fig. 22). To remedy this, either zoom in then out using the scroll wheel, or toggle between centerline and normal view using the Ctrl+A key to refresh the view.

### Part 4: Conflict Areas

In order to avoid collisions in an intersection where there are no dedicated turning movement signals, you will have to define the right-of-way for permitted movements by setting conflict areas. A conflict area can be defined wherever two links/connectors in the network overlap and the user can define which of the conflicting links has right of way (if any).

Note: Conflict areas are a new alternative to priority rules and are recommended in most cases because they are more easily defined and the vehicle behavior is more intelligent.

- Click the **Conflict Area** icon:
  - Left click a link to select it, and left click near two intersecting links/connectors within the intersection. The two approaches should be bordered in yellow with the conflict area completely filled in. (Fig. 23)
  - Right click on the highlighted portion to toggle between the different right-of-way options: Green means that that movement takes priority if a car is approaching from each movement. (Fig. 24)
    - The red option can be used where priority is determined by arrival such as at a 4-way stop
    - The yellow option means that no priority is defined.
At signalized intersections, conflict areas only need to be defined for movement which could conflict during the same green phases.

- Therefore you do not need to define the conflict area for southbound left with eastbound through because the signal would not allow this conflict.

In each of the side intersections, 10 conflict areas should be defined (Fig. 25):

- 4 for each of the left turn movements conflicting with opposing through movement.
- 2 for the left turn and opposing right turn movements entering into the same lane of the NB and SB roads (right turn gets priority).
- 4 for giving the through movements priority over a right turn on red into same lane.

Repeat similar process for middle intersection.

In the middle intersection, 8 conflict areas should be defined (Fig. 26):

- 2 for the NB and SB left turn movements conflicting with opposing through movement (EB and WB will not conflict with through movement because of dedicated turning phase).
- 2 for the left turn and opposing right turn movement entering into the same lane of the NB and SB roads (here, the left turn gets priority because of dedicated left turn phase)
- 4 for giving the through movements priority over a right turn on red into same lane

![Conflict Areas for Middle Intersections](image)

**Figure 26. Conflict Areas for Middle Intersections**

Notes:
- If you are having trouble picking up a conflict area, left click in the general area and then use TAB to toggle between surrounding conflict areas.
- If you define a conflict zone that does not need to be, keep clicking until both movements are yellow and then click away from the area and it will disappear.

### Part 5: Creating Output Files

Intro: Once the network is created the simulation can be run. However, the simulation only provides a visual representation of the system unless outputs are specified. VISSIM can provide information on travel times, delay times, queue lengths, green time distribution, specific vehicle information, etc. We will create output files that provide the travel times and delay times on the system.

#### 5.1 Define Travel Time Sections

Travel time sections have to be defined to get either travel time or delay data. VISSIM calculates the average travel time (including wait and dwell times) from the start to the end of the defined section.

- Click the define/edit travel time measurements icon:
- Select the link for the start of the section by left clicking on it.
- Select the desired start location with a right click. The start location will be shown with a red bar.
  - Select your first start point approximately 350 ft before the first intersection traveling east (see Fig. 27)
- With a left click select the destination section and select the location with a right click.
  - Select your first destination point approximately 350 ft after the last intersection (see Fig. 27)
- The Create Travel Time Measurement dialog box will come up (Fig. 28). Give the travel time section a unique number and name. Make sure Write to File is selected. Leave all other defaults and click OK.
- Repeat to create three more travel time sections:
  - Create sections traveling south to north through intersections 1 and 2. The sections should start and end approximately 175 ft before and after the intersection.
  - Create a section making a left turn through intersection 2. Start the section approximately 100 ft before the left turn pocket and end it approximately 100 ft after the intersection.
  - The N/S for Intersection 1 and the left turn travel time definitions for this demonstration are shown in Fig. 29.

![Figure 27. Start and end point for first travel time section.](image)

![Figure 28. Travel Time Measurement dialog box.](image)

![Figure 29. Additional travel time segments.](image)
5.2 Create Travel Time and Delay Output Files
Two types of output files can be created, raw data or compiled data. Raw data files give the travel times for every vehicle. We will use compiled data that provide averages.

- Go to Evaluation → Files. The Evaluations (File) dialog box will appear.
- Check travel time and select the Configuration button that becomes available. The Travel TT-Measurements Configuration dialog box will appear.
- Make sure all travel time sections appear. The model will be run for 3600 seconds (1 hour) starting at time 0. An interval of 900 seconds will give ¼ hour information. Check the box next to the Compiled Data option. See Fig. 30 to see all setting for the dialog box. Then click OK.

![Figure 30. Settings to create travel time output file](image1.png)

![Figure 31. Settings for delay output.](image2.png)

- Back in the Evaluations (File) dialog box check Delay and select the Configuration button that becomes available. The Delay Measurements-Configuration dialog box will appear.
- Click New to add a travel time segment. Select your first travel time segment and select OK. Repeat to add all four segments. Again set parameters as 0, 3600, 900 and check Comp. Data. See Fig. 31 for completed Delay dialog box.
- Click OK to return to the Evaluations (File) dialog box and click OK again.
Part 6: Running the Simulation

Now that a usable network has been created and outputs defined it is time to run the model.

- To run the simulation click the play button:

NOTE: The simulation will be running at top speed. To slow the simulation down, go to `Simulation → Parameters`. The maximum simulation speed will be selected. To slow the simulation down unselect maximum and manually adjust the speed. You can also use the “+” and “-“ buttons on the number pad part of your keyboard to speed up or slow down simulation speed.

NOTE: To view the simulation in 3-D, go to `View → 3D Mode`. To move in and out use the zoom button: (In 3D mode you have to hold down the left mouse button to zoom)

Use the rotate button: to change the view. Fig. 31 shows an example 3-D view.

![Figure 31. Example 3-D view of simulation.](image)

- After the simulation has finished running, your two output files will be created. They will appear in the same directory file as your network file. The travel time output text will be saved as a *.RSZ file. The delay output text will be a *.VLZ file.

Woo-hoo! You’re done with this tutorial!